Jump to content
squidmb

dataform.ocx will not register

Recommended Posts

I am using a Windows 10 system for the conversion to VB.net. 
Most has gone swimmingly, but I get "Did not find a registered ActiveX control
in ....\dataform.ocx" error in the new build. 

dataform.ocx was missing from the project, so I downloaded version 6.0.0.8169
(file size 529 kB, date modified 06/24/1998 1:00 AM) from Microsoft and
placed it in C:\Windows\SysWow64. 

Then I attempted to register it using Regsvr32.exe.  I get the error "Module
dataform.ocx was loaded but the call to DLLRegisterServer failed with error code
0x80004005".  The 0x80004005 error code means there is a permissions problem. 
However, I am logged in as an administrator AND ran the program as Administrator. 

I have tried un-registering it (same error).  Any suggestions?  Getting rid of
dataform.ocx altogether is an option, but I'm not sure what that involves (what
VB.net substitutions are needed for the wrapped-up VB6 ActiveX needs).

Thanks,
Dave

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use